Login | Register

Need Help Please. Load Library Failed.

A place to discuss topics related to Core Temp
  • Author
    Message

Need Help Please. Load Library Failed.

Postby MoRbIdBoY » Thu Nov 07, 2013 12:33 pm

Hey guys, you may be able to help me (better than Microsoft). Love Core Temp, had it running for ages with the desktop gadget. Love it.

But then "MICROSOFT!!! ARGGG!!!". I recently decided to upgrade from VS 2012 to VS 2013. All kinds of band things started happening (including a problem with the Core Temp gadget). Long story short anyway (I have Windows 7 x64 SP1 ):

I seem to have a problem with windows scripting host. The gadget seems to fail with "load library error". The error is on the line with new ActiveXObject("WScript.shell"), and I get "Automation Server Can't Create Object". It returns a null object. Not too great at debugging this, it's made tricky by the way only the sidebar.exe application exposes the "System.Gadget" object. But anyway, to continue:

I get the same error when I try to create an Empty C++ project in Visual Studio 2013 (the IDE uses WScript.shell to create the empty project and seems to be encountering the same problem as your gadget).

I've tried this so far:

Someone mention to re-register windows scripting via:
%systemroot%\system32\regsvr32 %systemroot%\system32\vbscript.dll
%systemroot%\system32\regsvr32 %systemroot%\system32\jscript.dll
%systemroot%\system32\regsvr32 %systemroot%\system32\dispex.dll
%systemroot%\system32\regsvr32 %systemroot%\system32\scrobj.dll
%systemroot%\system32\regsvr32 %systemroot%\system32\scrrun.dll

Initially had a problem with these next two, but fixed them by deleting their class entries in the registry before re-registering them with the commands below:
%systemroot%\system32\regsvr32 %systemroot%\system32\wshext.dll
%systemroot%\system32\regsvr32 %systemroot%\system32\wshom.ocx

and the WOW64 versions:

%systemroot%\syswow64\regsvr32 %systemroot%\syswow64\vbscript.dll
%systemroot%\syswow64\regsvr32 %systemroot%\syswow64\jscript.dll
%systemroot%\syswow64\regsvr32 %systemroot%\syswow64\dispex.dll
%systemroot%\syswow64\regsvr32 %systemroot%\syswow64\scrobj.dll
%systemroot%\syswow64\regsvr32 %systemroot%\syswow64\scrrun.dll

I suspect, THESE TWO FILES MAY BE THE PROBLEM:
%systemroot%\syswow64\regsvr32 %systemroot%\syswow64\wshext.dll
%systemroot%\syswow64\regsvr32 %systemroot%\syswow64\wshom.ocx

Everything registers OK except those last two in the syswow64 folder, wshext.dll and wshom.ocx. I get:
0x80040201 wshext.dll was loaded but the call the DllRegisterServer failed.

I've even tried altering my browser security for "Local Zone" / "initialize and script ActiveX controls not marked safe for scripting" and "Advanced Internet Options" / "Allow active content to run in fies on My Computer".

No change. Completely at a loss. Even un-installed Visual Studio 2013 and went back to Visual Studio 2012, but now I get the same error message in VS2012 (I followed this article to uninstall Visual Studio 2012 before installing Visual Studio 2013 (it lists the things I've uninstalled as part of visual studio): http://support.microsoft.com/kb/2771441/en-gb

Anyway, any help is appreciated guys. I'm completely stuck. Cheers.

EDIT:

EDIT:

When I try to create in a script:
var oShell = new ActiveXObject("WScript.Shell");

I get a null object... whereas if I try to create something like:
var ajaxrequest= new ActiveXObject("Msxml2.XMLHTTP")

I get a IXMLHTTPRequest object. So w/e the problem is, it's something to do with the "WScript.Shell" ActiveX object. I can run WScript and CScript from the command prompt with no problem.
MoRbIdBoY
New User
 
Posts: 2
Joined: Thu Nov 07, 2013 3:33 am

Re: Need Help Please. Load Library Failed.

Postby MoRbIdBoY » Sun Nov 10, 2013 12:51 pm

Resolved by importing this into the registry:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\TypeLib\{F935DC20-1CF0-11D0-ADB9-00C04FD58A0B}]

[HKEY_CLASSES_ROOT\TypeLib\{F935DC20-1CF0-11D0-ADB9-00C04FD58A0B}\1.0]
@="Windows Script Host Object Model"

[HKEY_CLASSES_ROOT\TypeLib\{F935DC20-1CF0-11D0-ADB9-00C04FD58A0B}\1.0\0]

[HKEY_CLASSES_ROOT\TypeLib\{F935DC20-1CF0-11D0-ADB9-00C04FD58A0B}\1.0\0\win64]
@="C:\\Windows\\system32\\wshom.ocx"

[HKEY_CLASSES_ROOT\TypeLib\{F935DC20-1CF0-11D0-ADB9-00C04FD58A0B}\1.0\HELPDIR]
@="C:\\Windows\\system32"

I needed to take ownership of that entire branch before importing, as it was locked down to "trusted installer". I don't know why the entries under this branch were missing, as I say, trusted installer had ownership. Reregistering wshom.ocx did not recreate the branches (Microsoft Bug?). Had to copy those entries from a different location HKEY_LOCAL_MACHINE\SOFTWARE\Volatile\00\MACHINE\SOFTWARE\Classes\TypeLib\{F935DC20-1CF0-11D0-ADB9-00C04FD58A0B} ??

Hope this helps someone else out who has "Automation Server can't create object" or can't run scripts or create an "WShell.script" ActiveX object.
MoRbIdBoY
New User
 
Posts: 2
Joined: Thu Nov 07, 2013 3:33 am

Re: Need Help Please. Load Library Failed.

Postby The Coolest » Tue Nov 12, 2013 9:50 am

Hello,

I'm sorry I haven't replied sooner, but I wasn't sure what I could add to this thread before your update.
It's great to know that you were able to sort out the problem yourself, and thank you for updating the thread with a possible solution for other gadget users.
Member of our O/C Folding @ Home team
"<The_Coolest> you can't unwaste wasted CPU cycles" - Start FOLDing now!
Main rig:
Core i7 2600K 3.4GHz @ 4.5GHz (Scythe Mugen2) / Mobo: Biostar TP67XE / SSD: Crucial M4 128GB (+ HDDs) / GPU: HD5450 / Mem: 4x4GB DDR3-1600 G.Skill 4GBXL RipJaws X - 16GB total / PSU: Seasonic S12II 620W.
Secondary rig:
Core i3 540 3.06GHz @ Stock / Mobo: MSI H55M-ED55 / GPU: Integrated / Mem: 2x2GB DDR3-1600 G.Skill 4GBRL RipJaws - 4GB total / PSU: FSP ATX350-PNR 350W.

Core Temp - Accurate temperature monitor for Intel's Core/Core 2 and AMD64 processors
User avatar
The Coolest
Site Admin
Site Admin
 
Posts: 2961
Joined: Tue Feb 18, 2003 7:48 pm
Location: Tel Aviv, Israel

Return to Discussion

Who is online

Users browsing this forum: No registered users and 3 guests