Login | Register

Window will not show after moving multiple displays

Post about bugs you find in Core Temp so they can be addressed and fixed efficiently
  • Author
    Message

Window will not show after moving multiple displays

Postby phormix » Mon Nov 30, 2015 7:36 am

In my case, I have a machine with 3 displays. The bug is reproducible in the following example

If they are in the following order (brackets denote the "main" display)

[#1] #3 #2

And the CoreTemp window is on display #2


Then, the displays are reordered (while coretemp was closed) to be

#2 [#1] #3

The coretemp window is stuck to the right of display #3, however there is no longer an active display there. The window cannot be moved or seen, unless one mucks with the displays.

I'm assuming this is because the window position is somehow saved based on a X,Y value, and that in the initial setting X goes to from
0-3240 (these are 1080p displays)
but in the second example X is from
-1080 to +2160

If the window location was saved at e.g. 2500,300, it would no longer on any of the active displays.

If possible, it might be a good idea to either
a) Check if the last saved X,Y location is still valid (if not, snap back into an available window)
or
b) Have some option in the tray-icons to reset the location of the window back to 0,0 or some other sane value.

While I was able to restore the window by messing with my desktops, in some cases this might not be possible (changed video cards, missing a monitor, laptop with a monitor extension that is no longer plugged in, etc).
phormix
New User
 
Posts: 1
Joined: Mon Nov 30, 2015 7:23 am

Re: Window will not show after moving multiple displays

Postby The Coolest » Fri Feb 26, 2016 7:42 pm

Thanks.
This should be fixed in the next release.
Member of our O/C Folding @ Home team
"<The_Coolest> you can't unwaste wasted CPU cycles" - Start FOLDing now!
Main rig:
Core i7 2600K 3.4GHz @ 4.5GHz (Scythe Mugen2) / Mobo: Biostar TP67XE / SSD: Crucial M4 128GB (+ HDDs) / GPU: HD5450 / Mem: 4x4GB DDR3-1600 G.Skill 4GBXL RipJaws X - 16GB total / PSU: Seasonic S12II 620W.
Secondary rig:
Core i3 540 3.06GHz @ Stock / Mobo: MSI H55M-ED55 / GPU: Integrated / Mem: 2x2GB DDR3-1600 G.Skill 4GBRL RipJaws - 4GB total / PSU: FSP ATX350-PNR 350W.

Core Temp - Accurate temperature monitor for Intel's Core/Core 2 and AMD64 processors
User avatar
The Coolest
Site Admin
Site Admin
 
Posts: 2961
Joined: Tue Feb 18, 2003 7:48 pm
Location: Tel Aviv, Israel

Return to Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest